Lecture des contenus multimédia HTML5 « propriétaires » sous Linux

Les contenus audio et vidéo HTML5 dits « propriétaires » incluent tous les formats multimédia dont le décodage est soumis au paiement de royalties tels que les MP4/H.264 pour les vidéos ou l’AAC pour l’audio.

Test du support par votre navigateur

Pour tester si votre navigateur supporte la lecture de ces formats propriétaires, essayez de lire la vidéo ci-dessous.


Installer les paquets logiciels requis pour la lecture des formats propriétaires.

Si vous ne pouvez pas lire la vidéo de test :

  1. Ouvrez un Terminal (interpréteur de commande)
  2. Lancez la commande suivante :
    sudo /opt/vivaldi/update-ffmpeg
  3. Relancez votre navigateur.

La commande précédente est adaptée à une version stable de Vivaldi, installée via les paquets RPM ou DEB officiels. Si le chemin est erroné ou si vous obtenez un message d’erreur « commande non trouvée », ouvrez la page vivaldi://about et repérez la ligne du Chemin d’accès à l’exécutable pour noter où Vivaldi est installé et adapter la commande en conséquence.

Si vous ne disposez pas des permissions requises ou que vous ne souhaitez pas utiliser sudo, consultez l’article suivant « Running the the Vivaldi Linux update-ffmpeg and update-widevine scripts without using root ».

Paquets (ni deb, ni rpm) non officiels

Si vous utilisez une distribution Linux qui n’est pas basée sur des paquets rpm ou deb, et que la méthode ci-dessus ne fonctionne pas, merci de contacter les personnes qui maintiennent le paquet Vivaldi pour votre distribution pour obtenir de l’aide en cas de difficulté de lecture des formats propriétaires après installation. Si elles ne sont pas sûres du meilleur moyen de résoudre ces problèmes, vous pouvez leur conseiller de se référer au guide suivant : guide on how to configure proprietary media in non-official Vivaldi Linux packages.


Résolution de problèmes

Si la vidéo de test ci-dessus ne se lit toujours pas, merci de rédiger un rapport de bug décrivant que vous utilisez Linux et l’impossibilité de lire les formats multimédia propriétaires. Mentionnez bien la distribution utilisée et sa version.

La plupart de services de diffusion audio/video nécessitent l’installation des Extensions Encrypted Media (EME) pour fonctionner. Si vous pouvez lire la vidéo de test ci-dessus mais continuez à rencontrer des soucis sur des services de streaming, vous devrez aussi consulter la page d’aideWidevine CDM (pour le support EME/DRM) sous Linux.
 

Was this page helpful?